Podium

System Requirements

System Requirements

Previous topic Next topic  

System Requirements

Previous topic Next topic JavaScript is required for the print function  

What are the System Requirements?

 

Office 2007 or Office 2010 (32-Bit ONLY)

Microsoft .NET  Framework 2.0

 

SystemRequirements

 

If your Computer can install and run Office 2007 or Office 2010 32-bit then it can run BrightSlides Podium.  Enjoy!